Uncategorized

Make ESP look better by disabling FSIA

Leave it to Microsoft to turn everything into an acronym.  So let me start with definitions:

  • ESP = Enrollment Status Page.  This shows the progress of the Windows Autopilot device provisioning process, in two different phases:  device ESP, which tracks the device configuration, and user ESP, which tracks the user configuration after the user is signed in for the first time.
  • FSIA = First Sign-In Animation, the pulsing blue/black screen that shows up the first time you sign into Windows.  During Autopilot, it shows up in between device ESP and user ESP.

This is what the FSIA screen looks like:

image

But this animation can be turned off via a policy.  This policy can be set via Group Policy or via MDM, and unfortunately neither of those are exposed through Intune (or at least I can’t find them).  But it’s easy enough to add as a custom policy:

image

The critical piece of that is the OMA-URI:

./Device/Vendor/MSFT/Policy/Config/WindowsLogon/EnableFirstLogonAnimation

This is documented in the Policy CSP documentation.  Once you have it configured, you can assign it to an appropriate group of devices.  So what does the process look like with that policy in place?  Here’s a short video, showing the end of device ESP, the user sign-on without FSIA, and then user ESP:

That is a slightly less jarring transition.  (It also has another side benefit: It reduces the load on the device CPU.  The animation is compute-intensive for some reason.)  Try it out yourself.

6 replies »

  1. Nice tip. They should turn this off by default during ESP or maybe add it as a switch/checkbox in the ESP settings in the Intune portal.

    Like

    • If you are going to use user ESP, it’s an optimization that you can make. But it does nothing in regards to that choice of user ESP or no user ESP (although I’m working on another blog about that).

      Like

  2. FSIA caused a “black screen of hang” for us during ESP – the only operational item was the mouse so long press on the power was the only way to get the machine back up. Once reset ESP continued and all was OK…but disabling FSIA was a better solution.

    Like

Leave a Reply to Michael Niehaus Cancel reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s